WEB DESIGN

Ini adalah bagian kedua
dari modul web design, pada modul ini berisi
tutorial Macromedia / Adobe Dreamweaver.

Modul ini disertakan file praktek untuk
memudahkan dalam pembelajaran.
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Pendahuluan

Macromedia Dreamweaver MX 2004 (Dreamweaver) merupakan salah satu software yang mempunyai
banyak sekali kemudahan dalam pengoperasiannya namun juga sangat powerfull dalam pembuatan
website. Salah satu keunggulannya adalah kemudahannya dalam berinteraksi dengan macromedia Flash
(Flash), sebuah tools animasi yang sangat populer di internet.

Interface Dreamweaver

Interface Dreamweaver atas Main menu, Insert Menu, Document Menu dan area kerja, bersama dengan
Properties Inspector, panel-panel dan jendela-jendeal yang terlihat saat membuka palikasi ini. Komponen-
komponen interface adalah :

1. Bar
a. Main Menu Bar
b. Insert Bar
c. Document Bar
2. Panels
a. Design
b. Application
c. Files
d. TagInspector
e. Codes
f.  History
3. Properties Inspector

Insert Bar

Untuk membuat website atau halaman, Insert bar bagian tools untuk memasukkan berbagai macam
image, tabel, layer dalam dokumen. Untuk membuka Insert bar, ikuti langkah-langkah berikut :

1. Klik menu View.
2. Klik option Toolbar.
3. Pilih dan klik option Insert. Insert bar akan terbuka

Fungsi dan kegunaan tools pada Insert Bar adalah sebagai berikut :

1. Common
Common tab memungkinkah kita membuat objek yang biasa digunakan dalam website, yaitu :
Hyperlink, email link, named anchor, table, images, media: plugin, date, comment, templates dan tag
chooser.

2. Llayout
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Dengan menggunakan Layout tab kita dapat menampilkan tabel dalam mode tampilan
Standard,Expanded ataupun Layout. Fitur-fitur di dalamnya adalah : Table, Insert Div Tag, Draw
Layer, dan lain sebagainya.

3. Teks
Teks yang telah di format dapat dimasukkan menggunakan tab Text dalam Insert bar dengan
menggunakan fitur-fitur berikut : fon tag editor, bold, itlic, strong, emphasis, paraghraph, block
quote, preformatted, dan lain sebagainya.

4. Forms
Untuk membuat form dan memasukan elemen-elemennya, digunakan Form tab yang memiliki fitur-
fitur berikut ini: form, text field, hidden field, text ares, check box, dan lain sebagainya.

5. Application
Kita dapat menambahkan Server Behavior pada halaman dengan menggunakna Application tan yang
memiliki fitur-fitur berikut : recordset, stored procedure, dynamic data, repeted region, dan lain
sebagainya.

6. HTML
Anda dapat memasukkan berbagai objek HTML untuk halaman Web. Objek-objek tersebut adalah :
horizontal rules, head contents, cripts, dan lain sebagainya.

7. Flash Element
Tab ini terdiri atas satu objek yang memudahkan anda menambahkan slideshow flash ke halaman
anda. Objek ini bagus untuk menampilkan koleksi objek yang banyak

8. Favorites
Fitur yang membantu kita untuk mengelompokkan tab yang sering digunakan.

Tips: Untuk membuka panel Insert anda dapat menggunakan Ctrl+F2 dan untuk membuka properties Ctrl+F3
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Site Control ‘

Menentukan Site
1. Buka Dreamweaver MX 2004. Di jendela Manage Sites, klik tombol New, kemudian pilih Site dari
menu drop down. Klik tab advanced di atas kiri panel Site Definition (tab kedua dari kiri).
2. Ketikkan nama site, misalnya Proyek Pertama, di bagian Site Name, lalu browse folder
(01_sitecontrol) sebagai Local Root Folder-nya.

3. Pastikan kotak cek Refresh Local File List AutomaticAlly dan enable cache aktif . Setelah itu klik Ok
dan Done

Membuat dokumen, menyimpan dan menampilkannya pada browser

W 1. Pilih File->New untuk membuat dokumen baru.
e “": — e Kotak dialog akan muncul
::hi’« :": 2. Pastikan kategori Basic Page terpilih dan
z": e eniem kemudian pilih HTML di bagian kanan. Hal ini

memberi perintah ke Dreamweaver untuk

membuat halaman HTML.

Klik check box Make Document XHTML copliant.

et o ot Klik tombol Create

(oo ) (Goowmn]  sotmamcmne. Come ) (o) 4. Pilih Modify/Page Properties. Di kotak dialog
Page Properties, pastikan kategori
Title/Encoding terpilih, ketikkan Welcome to My
Site di kotak Title. Klik Apply lalu OK

o e 5. Pilih File->Save As untuk menyimpan file dengan

RC|([d ¢ ¥a|D nama index.html

= I Site - Proyek Pertama (C:\Documer

420 images
@ index.btml

Files

Rk
Menambah Gambar ‘

1. Aktifkan file index.html pada latihan sebelumnya

2. Klik tab Common di Insert Bar, lalu plih ikon Images, dan pilih opsi images, atau gunakan shortcut
Ctrl+Alt+l. Di kotak dialog yang muncul, browse file logo01.jpg yang terdapat di dalam folder
Images. Klik OK.

3. Ulangi langkah no.2 untuk memasukankan gambar logo02.jpg di dalam folder Images ke dalam

halaman. Non-akifkan seleksi pada gambar, lalu tekan Enter untuk memberi jarak pada gambar
berikutnya.
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4. Ulangi langkah berikutnya untuk memasukan gambar but01.jpg, but02.jpg, but03.jpg, but04.jpg,
but05.jpg, but06.jpg, separator.jpg dan temp01.jpg kemudian simpan dan tampilkan melalui
browser dengan menekan F12. Lihat hasilnya di bawah ini.

Menambah Teks ‘

1. Klik di sebelah kanan gambar PDA, lalu enter untuk membuat jarak. Ketikkan home, lalu tekan
spacebar. Selanjutnya tekan Shift+Backslash(\) untuk menambah pipe (|). Dan tekan spacebar di

keyboard.
2. Lanjutkan dengan mengetik About Us | Support | Your cart | Services | Contact Us

Memposisikan Gambar dan Teks di Tengah Halaman
1. Klik gambar logo01.jpg untuk membuat seleksi.
2. DiProperties Inspector, klik tombol Align Center
3. Gunakan tombol Shift untuk membuat seleksi pada gambar yang lainnya dan semua teks yang
berada di bawahnya sekaligus.
4. Simpan dan tampilkan melalui browser.
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@000

COMPANY.NAME

COMPANY:SUOGAN/HERE

Ada tiga jenis yang dapat kita buat menggunakan list, yaitu Unordered List, Ordered List, Nested List

Membuat Unordered List

Link |

=4
| 1z, 22 £= 22 Target

[ Page Properties. .. ] List

1. Pilih File -> New untuk membuat dokumen baru, pilih HTML
Ketikan “Daftar Mata Diklat : “, kemudian enter dan Klik ikon Unoreder List. Ketikan tulisan berikut
ini:
¢ Instalasi Software
e |Instalas PC
e Sistem Operasi jaringan
e Web Design

3. Simpan dengan nama unordered.html dan buka melalui browser dengan menekan F12. Hasilnya
seperti di bawah ini.
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Daftar Mata Diklat/Pelajaran :

® Instalasi PC
o Instalast Software
e Sistem Operast Jaringan

Membuat Ordered List
E =E E = Link
= IS EE 2= Target

[ Page Properties... ]

1. Pilih File -> New untuk membuat dokumen baru, pilih HTML
Ketikan “Daftar Barang Elektronik: “, kemudian enter dan Klik ikon oreder List. Ketikan tulisan
berikut ini :
1. Televisi
2. Tape Recorder
3. LemariEs
4. Radio
3. Simpan dengan nama ordered.html dan buka melalui browser dengan menekan F12. Hasilnya
seperti di bawah ini.

Daftar Barang Elektronik

1. Telewsi [}S
2. Tape Recorder
3. Leman Es

4. Radio

Membuat Nested List
1. Pilih File -> New untuk membuat dokumen baru, pilih HTML
2. Klik ikon oreder List. Ketikan tulisan berikut ini :

1. Satu

Dua

Dua Satu

Dua Dua

Dua Dua A

Dua Dua B

Dua Dua C

Dua Tiga

N WUV A WN
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9. Tiga

10. Empat

11. Lima
3.

= O M0 RN

_—

4. Blok dari nomor iii hingga V dan klik ikon Text Indent.

1. Satu
2. Dua
1
i
1.
v
V.
.
3. Tiga
4. Empat
5. Lima

5.

ua Dua &
ua Dua B

i
5
-1
i

WDua Dua B

i
il
[l
[

g —

+=

|
(M

Targ

Pane Pronerties. ..

Dua Satu
Dua Dua

Dua Dua A

Dua Dua C
DuaTiga |

seperti di bawah ini.

1. Satu
2. Dua
1. Dua Satu
1. Dua Dua
1. DuaDua &
2. DuaDuaB |
3 DuaDuaC
. Dua Tiga
3. Tiga
4. Empat
5. Lima

—

. Satu
Dua

Program Keahlian
Kelompok Teknologi Komputer dan Jaringan

Blok pada nomor urut 3 hingga 8 seperti gambar di bawah ini dan klik ikon Text Indent

Dua Satu
Dua Dua
Dua gua A
Dua-ua B
DuaDuaC
Dua Tiga

Simpan dengan nama ordered.html dan buka melalui browser dengan menekan F12. Hasilnya

Modul Program Mata Diklat Web Design—Macromedia Dreamweaver MX 2004- Aris Supriadi (aarriiss.com)
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Memodifikasi Page Properties ‘

Joot | tiodfy | I Gommends s Window_Hee 1. Buka file Index.html yang sebelumnya digunakan.
:"’““"“ - 2. Pilih Edit/Preferences. Pastikan kategori General
S €, Selection Properties ptul tersorot di bagian kiri jendela. Hilangkan tanda dari

check box Use CSS Instead of HTML Tags.
3. Pilih Modify/Page Properties atau gunakan shortcut

Edit with External Editor Ctri+).

Tag Libearies....

oot 4. Atur jendela Page Properties dan jendela dokumen
[Ersconcemess e

terdisplay secara bersamaan.

5. Klik kotak kecil di samping kanan Background dan
gerakan Eye Dropper ke warna yang diinginkan. Klik
Apply.

6. Ketikkan #000000 di kotak isian Text Color

7. Pilih Links pada Category. Isikan #000642 pada kotak
Link Color dan #666666 di kotak isian Visited Links dan
#000642 pada isian kotak Active Link.

8. Simpan dan buka melalui browser.
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Membuat Link dengan Point to File

Point to File merupakan metode alternatif untuk membuat link pada halaman web

Salinlah folder 02_link ke dalam komputer dan gunakan sebagai Local Root Folder.

Buka file index.html. aktifkan panel Files. Atur posisi jendela dokumen dan panel Files.

Seleksi gambar about.gif (about us). Di Properties Inspector, klik dan tahan ikon Point to File di
samping kotak Link. Setelah itu drag Point to File ke file aboutus.html dalam folder aboutus yang
berada di panel Files. Perhatikan kotak Link men-display file yang di link.

Ulang langkah nomor 3 untuk membuat link gambar frames.gif (frames) dengan file frames.html di
dalam folder frames, lalu gambar locations.gif (locations) dengan file locations.html di dalam folder
locations, dan gambar contact.gif (contact) dengan file contactus.html di dalam folder contactus
dengan menggunakan Point to File.

Simpan dan tekan F12 untuk menampilkan halaman ke browser.

Membuat Link Email

1.
2.

Buka file email.html. Klik dalam sel di samping kiri baris General Information.

Klik ikon E-mail Link di tab Common. Di kotak dialog E-Mail Link, ketikkan General Information di
kotak Text, kemudian tekan tombol Tab, dan ketikkan info@website.com di kotak E-Mail. Klik OK.
Klik di di dalam sel di sebelah kiri baris Order/Sales Information.

Klik ikon E-Mail Link di tab Common pada Insert bar. Pada kotak dialog E-Mail Link, ketikkan
orders@website.com di kotak Text. Kemudian orders@website.com di kotak E-Mail.klik OK.

Klik di dalam sel disamping kiri baris Comments/Suggestions, kemudian ketikkan

comments@website.com di sel yang kosong itu, dan sorot teks dengan meng-klik dan men-drag dari

teks sampai dengan akhir tab.
Di Properties Inspector, ketikkan mailto:comments@website.com dalam kotak Link, dan tekan

Enter.
Simpan dan tekan F12 untuk melihat halaman web di browser.

Membuat Named Anchor

1.
2.
3.

Buka file anchor.html

Klik di atas kata Name : Warp

Klik ikon Named Anchor atau gunakan shortcut Ctrl + Alt + A. Di kotak dialog Named Anchor,
ketikkan warp, dan klik OK.

Klik di atas kata Name : Bean, kemudian tekan Ctrl + Alt + A. Dalam kotak dialog Named Anchor,
ketikkan bean, dan klik OK.

Klik di atas kata Name : Zody (mint jelly), kemudian tekan Ctrl + Alt + A. Dalam kotak dialog Named
Anchor, ketikkan zodymint, dan klik OK.

Klik di atas kata Name : Zody (pink dew), lalu tekan Ctrl + Alt + A. Dalam kotak dialog Named
Anchor, ketikkan zodypin , dan klik OK.

Klik di atas kata Name : Pillow, lalu tekan Ctrl + Alt + A. Dalam kotak dialog Named Anchor, ketikkan
pillow, dan klik OK.

Modul Program Mata Diklat Web Design—Macromedia Dreamweaver MX 2004- Aris Supriadi (aarriiss.com)
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8. Klik di atas kata Name : Toot, lalu tekan Ctrl + Alt + A. Dalam kotak dialog Named Anchor, ketikkan
toot, dan klik OK.

9. Sorot kata “warp” yang ada di sudutt kiri atas halaman.

10. Di Properties Inspector, klik Point to File, kemudian drag ke Anchor Maker di atas teks Name :
Warp. Setelah itu, lepaskan tombol mouse untuk membuat link. Perhatikan di kotak Link terdapat
tanda #warp.

11. Ulangi langkah nomor 10 untuk membuat link anchor pada teks “bean” dengan Anchor Maker teks
Name : Bean, teks “zody/mint jelly” dengan Anchor Maker teks Name : Zody, teks “zody/pink
dew” dengan Anchor Maker teks Name : Pillow, teks “toot” dengan Anchor Maker teks Name :
toot.

12. Tekan F12 untuk melihat halaman dokumen di browser.

13. Kembali ke Dreamweaver, kemudian buat Anchor Maker dengan nama top di sebelah kiri “Click” di
bagian kiri atas halaman dokumen.

14. Sorot teks “top of page” di bawah keterangan kacamata Warp.

15. Di Properties Inspector, klik Point to File, kemudian drag ke Anchor Maker yang baru dibuat ( di
sebelah kiri kata “Click” ), dan lepaskan tombol mouse.

16. Ulangi langkah nomor 14 dan 15 untuk semua teks “Top of Page” yang lainnya.

17. Tekan F12 untuk mem-preview halaman di web browser, lalu simpan dan tutup dokumen.

Membuat Image Map

1. Buka file imagemaps.html

2. Seleksi gambar logo02.jpg

3. Di properties Inspector, ketikkan navbar di kotak Map.

4. Klik Rectangular Hotspot Tools. Setelah itu, klik dan drag di sekitar teks “frames”, klik Browse for File
dan browse file frames.html (folder frames). Klik OK.

5. Dengan image map masih terseleksi, ketikkan see the framesdi kotak Alt dalam Properties Inspector
dan klik Enter.

6. Ulangilangkah no 2-5 untuk membuat hotspot pada teks home dan site map pada file aboutus.html
(folder about us), locations.html (folder locations) dan contactus.html (folder contactus)

7. Simpan dan tekan F12 untuk melihat halaman dokumen di browser.
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Mengubah Border Tabel

1. Gunakanlah folder 03_table sebagai local root folder.

2. Buka file tableformat.html dan tekan F12. Perhatikan garis border table tidak ter-display di browser.

3. Kembali ke Dreamweaver. Klik di dalam tabel sehingga muncul <table> di Tag Selector yang terletak
di kiri bawah jendela dokumen. Klik kata <table> tersebut untuk membuat seleksi pada keseluruhan
tabel.

4. DiProperties Inspector, ketikkan 1 di kotak isian Border, kemudian tekan F12 untuk melihat
tampilan tabelnya.

5. DiDreamweaver, klik di dalam sel yang terletak di kiri atas tabel. Klik tombol Code untuk mengubah
tampilan. Klik dan drag untuk memilih &nbsp;, lalu tekan Delete pada keyboard. Penghilangan kode
ini bertujuan agar sel yang kosong tersebut tidak memiliki border di sekelilingnya. Tekan tombol
Design untuk kembali ke tampilan sebelumnya.

6. Simpan dan tekan F12 untuk melihat hasilnya.

Membuat dan Memodifikasi Tabel
1. Buka dokumen baru (Ctrl + N)
Save dengan nama firsttable.html
Ketikkan My First Table pada kolom Document Title. Tekan Enter.
Klik tombol Insert Table di tab Common pada Insert bar.
Di kotak dialog Insert Table, pastikan kotak isian Rows=6, Columns = 4, Width = 600 pixels, dan
Border Thickness = 1. Klik OK.
6. Buka panel Assets, lalu cari file e01.gif. klik dan drag gambar ini ke dalam sel di kiri atas. Lanjutkan

vk W

memasukkan gambar e02.gif, e03.gif, e04.gif, e05.gif dan e06.gif ke sel-sel yang ada di bawah
secara berurutan.

7. Klik dan drag untuk memilih dua sel tengah pada baris pertama. Di Properties Inspector, klik tombol
Merges selected cells using spans untuk merger kedua sel tersebut menjadi satu. Ulangi prosedur
ini untuk baris ke-2 sampai 6.

8. Klik gambar yang ada di dalam sel kiri atas. Perhatikan di Properties Inspector, lebar gambar
tersebut adalah 117 pixels. Kita perlu mengatur lebar sel tersebut menjadi 117 pixels.

9. Gerakkan kursor ke pinggir atas kolom pertama sampai berubah menjadi tanda panah hitam. Klik
satu kali untuk memilih keseluruhan kolom. Di Properties Inspector , isi kotak isian W=117.

10. Uloangi langkah no 8 dan 9 untuk mengubah lebar kolom tengah menjadi 408 dan kolom sebelah
menjadi 75.

11. Klik di dalam sel tengah atas, pilih Modify->Table->Insert Rows or Columns. Di kotak dialog yang
muncul, pilih Insert: Rows, Number of Rows:1, Where:Above the Selection.

12. Klik dan drag untuk memilih semua sel dalam baris yang baru dibuat. Klik tombol Merge selected
using cells spans di Properties Inspector .

13. Buka file tabledone.html sebagai pedoman untuk menambahkan teks dan warna pada tabel.

14. Simpan dan tekan F12 untuk menampilkannya melalui browser.
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Mengatur Posisi Gambar dan Teks dalam Tabel

1.
2.

10.

11.

Buka file bodycopy.html. tekan F12 untuk melihat halaman dokumen di browser.

Di Dreamweaver, buat dokumen baru dengan memilih File->New. Simpan dokumen tersebut
dengan nama align.html dalam folder Table.

Pilih Modify->Page Properties. Di kategori General, ketikkan Alignment With Tables di kotak isian
Title. Di kategori Appearance, isikan kotak isian warna Background = “DF9300”, dan warna text
="FFFFFF”. Klik Browse di samping pilihan Background Image. Browse file bkg_large.gif, dan klik
Open untuk kembali ke jendela Page Properties. Terakhir, klik OK.

Pilih Insert -> Table. Di kotak dialog yang muncul, isikan Rows=2, Columns=3, Table Width=600
Pixels, dan Border Thickness=0. Klik OK.

Pilih setiap kolom secara terpisah dan atur W (lebar ) setiap kolom 200 pixels di Proprties Inspector..
Buka file bodycopy.html

Seleksi teks yang memuat informasi alamat dan telepon, kemudian salin, dan paste di file align.html
pada kolom 2, baris 1 di tabel.

Pilih Window->bodycopy.html, kemudian seleksi, dan copy paragraf pertama. Buka dokumen
align.html, paste di kolom 2 baris 2.

Lanjutkan dengan meng-copy dan paste paragraf kedua ke dalam kolom 3, baris 2. Tutup dokumen
bodycopy.html.

Di dokumen align.html, klik di mana saja dalam baris kedua, lalu klik tag <tr> di Tag Selector untuk
memilih keseluruhan baris kedua tabel. Atur setting Vert di Properties Inspector menjadi Top.

DI Dreamweaver, seleksi tabel dengan meng-klik di dalamnya. Lalu memilih elemen <table> di dalam
Tag Selector. Pada Properties Inspector, isikan CellSpace = 10, tekan F12 untuk melihat hasilnya.
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Layout

Mengaplikasikan Tracing Image

1. Gunakan folder 04_layout sebagai Local Root Folder .

2. Buka file index.html. pilih Modify -> Page Properties, lalu klik Browse disamping pilihan Tracing
Image, dan browse file tracingimage.jpg yang ada di dalam folder Images. Terakhir, klik OK.

3. Pastikan Transparacy Slider di pilihan Image berada pada 100%. Klik OK.

4. Tekan F12 untuk mem-preview halaman dokumen pada browser. Perhatikan bahwa halaman Web
masih berupa blank document.

5. Di Dreamwever, pilih Modify -> Page Properties untuk mengakses Transparacy Image lagi.

6. Drag Transparacy Slider pada pilihan Image Transparacy ke posisi 50%. Klik OK.

7. Pilih File -> Save untuk menyimpan dokumen.

Menambah Layer

1. Buka file index.html, pilih Insert -> Layout Objects -> Layer.

2. Klik Layer Selection Handle yang berwarna putih , kemudian pindahkan, dan atur posisi layer tepat
pada posisi gambar Beverly yang ada di sebelah kanan.

3. Klik di dalam layer, lalu pilih Insert-> Image. Browse file Beverly.gif di folder Images, dan klik OK.

4. Aktifkan tab Layout di Insert bar, dan klik ikon Draw Layer. Selanjutnya, buat layer tepat pada posisi
gambar dan teks Melrose yang terletak di-tengah, lalu klik obyek Insert Image, dan cari file
Melrose.gif dalam folder Images. Terakhir, klik OK.

5. Ulangi langkah nomor 4 untuk menempatkan file Southcoast.jpg ke gambar tracing image paling
bawah.

6. Buat layer disekitar teks About l.a.Eyeworks. Di panel Assets, klik dua kali styles.txt, copy ke dalam
layer yang baru dibuat.

7. Tekan F12 untuk mem-preview halaman dokumen di browser. Kembal ke Dreamweaver, lalu simpan
file dan biarkan dokumen terbuka.

Mengubah Layer menjadi Tabel

1. Pilih Modify -> Page Properties. Hapus penanaman file di kotak Tracing Image (biarkan kosong).

2. Pada file index.html, pilih Modify -> Convert -> Layer to Table.

3. Dikotak dialog Convert Layer to Table, aktifkan pilihan Most Acurate di Table Layout, kemudian
aktifkan pilihan Use Transparents Gifts, dan aktifkan pilihan Prevent Layer Overlaps di Layout Tools.
Klik OK.
Angka 0 pada kotak isian Border merupakan default ukuran border pada saat layer diubah menjadi
tabel. Angka 0 juga menunjukkan bahwa border tersebut tidak akan terlihat bila halaman dokumen
ter-display di browser.

4. Tekan F12 untuk melihat hasilnya. Simpan dokumen dan biarkan tetap terbuka.

Mengubah Tabel menjadi Layer
1. Difile index.html, pilih Modify ->Convert -> Tables to Layers.
2. Dikotak dialog Convert Tables to Layers, non-aktifkan kotak cek Snap to Grid. Klik OK.
3. Klilayer yang berisi gambar Melrose (tengah), lalu dengan menggunakan Layer Selection Handle,
drag layer sehingga posisi bagian atasnya sejajar dengan posisi bagian bawah gambar Beverly (atas).
4. Ulangi langkah nomor 3 untuk memindahkan posisi gambar Southcoast (paling bawah).
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7.

Pilih Modify -> Convert -> Layers to Tables. Klik OK.

Pilih Modify -> Page Properties, ubah warna Background menjadi #DF9300. Atur warna Text =
#FFFFFF. Klik OK.

Tekan F12, lalu simpan dan tutup dokumen.

Tabel Layout dan Sel Layout

1.

P wnN

© o N oW

11.

12.

13.
14.

15.

16.

17.

18.

19.

20.
21.

Buka file navbar_done.html yang ada dalam folder 04_ layout.

Di tab Layout pada Insert bar, klik tombol Layout mode.

Klik OK pada kotak dialog yang muncul.

Tekan F12 untuk menampilkan halaman di browser. Perhatikan isi teks memanjang sesuai dengan
jendela browser.

Kembali ke Dreamweaver , tutup dokumen navbar_done.html.

Buat dokumen baru dan simpan file tersebut dengan nama navbar.html.

Klik ikon Layout Table pada panel Insert. Kita akan membuat tabel dalam dokumen.

Klik dan drag untuk membuat tabel dari sudut kiri atas, berukuran sekitar 575 x 200 pixel.

Di Insert bar, klik ikon Draw Layout Cell, untuk menggambar sel-sel terpisah di dalam tabel.

. Klik dan drag dari sudut kiri atas tabel layout untuk membuat sel dengan tinggi = 44 pixels dan lebar

sama dengan tabel.

Klik ikon Draw Layout Cell kembali, lalu gambar sel lainnya dari sudut kiri bawah sel yang baru
dibuat dengan ukuran 248 x 42 pixels. Gunakan Properties Inspector untuk mengubah ukuran sel.
Klik ikon Draw Layout Cell, lalu gambar sel yang lain di sebelah kanan sel yang terakhir dibuat
dengan lebar yang sama dengan tabel.

Klik tab Layout berwarna hijau di sudut kiri atas, lalu drag handle di kanan bawah tabel ke atas,
Klik border sel yang besar di atas untuk menyeleksinya. Di properties Inspector, ubah warna BG
menjadi #FFFFF.

Ulangi langkah no.14 untuk mengubah warna BG dua sel yang ada di bawah menjadi #DF9300.
Klik di dalam sel kiri bawah dan masukkan logo.gif ke dalam sel.

Klik di dalam sel kanan bawah dan masukkan gambar about.gif, frames.gif, locations.gif, dan
contact.gif ke dalam sel tersebut.

Gerakkan kursor ke garis tepi sel kanan bawah hingga border cell berwarna merah, lalu klik untuk
memilihnya. Di Properties Inspector, atur alignment Horz menjadi Right.

Klik tanda panah kecil di bagian bawah sel kanan bawah. Pilih Make Column Autostretch. Garis
kolom paling bawah akan berubah.

Di kotak dialog Choose Spacer Image, pilih Create a spacer Image file, lalu klik OK.

Simpan spacer.gif ke dalam folder Images.
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Frames

Membuat Frameset

1. Aturlah folder 05_frame_css sebagai Local Root Folder. Pilih File -> New untuk membuat dokumen
baru.

2. Matikan tampilan Grid bila masi terlihat (gambar kotak-kotak kecil seperti milimeter blok). Pilih
menu View -> Grid -> Show Grid (tanda centangnya harus tidak ada).

3. Pilih Modify/Frameset/Split Frame Left. Langkah ini menempatkan garis vertikal yang membagi
frame menjadi dua, yaitu frame kanan dan frame kiri.

4. Pilih File -> Save All untuk menyimpan frameset dengan nama frameset.html.

5. Perhatikan frame kanan tersorot dan kotak dialog Save As muncul lagi. Hal ini menunjukkan frame
nama yang akan disimpan selanjutnya. Isikan right.html di kotak isian Name pada kotak dialog
tersebut, dan klik Save. Setelah itu, ketikkan left.html dalam kotak isian Name pada kotak dialog
Save yang muncul, lalu klik Save.

6. Seleksi frameset, dan pilih Modify - > Page Properties. Isikan My First Frameset di kotak isian Title
dalam kotak dialog Page Properties, dan klik OK. Langkah ini mengubah nama judul Untitled
Document menjadi My First Frameset.

7. Pilih File -> Save All untuk menyimpan dokumen.

Memberi Warna pada Frame

1. Buka file frameset.html dari file latihan hasil tahapan sebelumnya.

2. Klik di dlaam frame kiri dan pilih Modify->Page Properties. Di kotak dialog Page Properties, isikan
Background = #DF9300, Text = #FFFFFF, dan Links=#FFFF00, Visited Links = #FFFF99, Active Links =
#FFFF99. Klik OK.

3. Klik di dalam frame kanan, lalu pilih Modify->Page Properties, dan isikan Background = #DF9300,
Text = #FFFFFF, dan Links=#FFFFO0O0, Visited Links = #FFFF99, Active Links = #FFFF99. Klik OK.

4. Buka panel Frames, lalu klik border paling luar untuk mengaktifkan frameset. Di properties
Inspector, aktifkan framekiri dan isikan 150 Pixels di kotak isian Column. Selanjutnya, pilih No di
menu Border, kemudian isikan 0 di kotak Border Width.

5. Simpan dan tekan F12 untuk melihat hasilnya di browser.

Link dan Target

1. Buka file frameset.html . klik pada frame kiri, dan ketikkan Contact Us.

2. Seleksi teks Contact Us, lalu klik folder yang ada di sebelah pilihan Link dalam Properties Inspector.
Browse file contactus.html yang terdapat dalam folder htmi.

3. Simpan dokumen. File -> Save All.

4. Tekan F12 untuk mencoba link yang telah dibuat.

5. Di Dreamweaver, pilih Window -> Frames. Perhatikan di dalam palet Frames sisi kanan dan kirinya
tertulis “(no name)”.

6. Klik kotak kiri palet Frames, kemudian ketikkan left di kotak isian Frame Name pada Properties
Inspector. Ulangi langkah yang sama untuk sisi kanan palet Frames dan beri nama right di kotak isian
Frame Name-nya. Tekan Enter.

7. Seleksi teks Contact Us di frame kiri dan pastikan Properties Inspector aktif.
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8. Klik segitiga yang menghadap ke bawah, di samping kotak isian target, lalu pilih right di menu pop-
up. Simpan dokumen (File-> Save All).

9. Tekan F12 untuk mem-preview halaman, aktifkan link-nya, sekarang halaman Contact Us berada di
frame kanan.

10. Simpan (File-> Save All).

Menambah Gambar Latar Belakang

1. Buka file frameset.html, klik dalam frame left.html (frame di sebelah kiri) dan pastikan kursor text-
insertion-nya berada di sebelah kanan teks Contact Us.

2. Pilih Modify -> Page Properties. Di kotak dialog Page Properties, klik tombol Browse di samping
kotak isian Background Image, kemudia browse file bg_eyeglasses.jpg di dalam folder images, dan
klik OK.

3. Lakukan hal yang sama dengan tahap nomor 2 untuk frame right.html.

Aktifkan panel Frames. Klik di border/pigura paling luar dari palet Frames untuk mengakses Column
Value di Properties Inspector.

5. Di Properties Inspector, klik frame kiri, lalu isikan 150 Pixels di kotak isian Column. Setelah itu, klik
frame kanan lalu isikan Relatives di kotak isian Column.

6. Simpan dan tekan F12.

Menggabungkan Latar Belakang diantara Dua Frame.

1. Buka file frameset2.html, kemudian klik di frame kiri dan pilih Modify -> Page Properties.

2. Dikotak dialog Page Properties, klik tombol Browse di samping Background Image. Browse file
bg_left.jpg yang terletak dalam folder Images. Klik OK.

3. Lakukan hal yang sama seperti nomor2 di atas untuk frame kanan, lalu browse file bg_right.jpg dan
klik OK.

4. Aktifkan palet Frames (Window/Frames). Kemudian klik border paling luar untuk mengakses ukuran
frameset di Properties Inspector.

5. Perhatikan panel Properties Inspector, klik pada frame/kotak yang kiri kemudian isikan Border = No,
Border Width = 0, Column Value = 150, dan Units = Pixels.

6. Klik frame kanan di Properties Inspector, lalu isikan Units = Relative. Save dokumen dan tekan F12.

Modul Program Mata Diklat Web Design—Macromedia Dreamweaver MX 2004- Aris Supriadi (aarriiss.com) 17




‘Q} VK PERGURUAN GKINI Program Keahlian

./ JI. Alur Laut Blok NN No. 1 Plumpang, Jakarta Utara Kelompok Teknologi Komputer dan Jaringan

CSS

Redefine HTML Style dengan Style Sheet

1.

9.

Buka redefine.html dan buka jendela Code Inspector untuk melihat kode HTML-nya. Perhatikan
bahwa halaman ini sangat sedikit menggunakan tag HTML dan tidak ada formatting.

Pilih Window-> CSS Style untuk megaktifkan panel CSS Style. Klik panah di kanan atas palet,
kemudian pilih New di menu yang muncul.

Di kotak dialog New Style, pilih Tag (redefine the look of specific Tags) di option Selector Type,
kemudian pilih body di menu drop-down Tag. Simpan style ini di dalam folder stylesheets.

Di kotak dialog Style Definition, di kategori Type, pilih Font = Verdana, Arial, Helevetica, sans-serif,
Size = 10 pixel. Dalam kategori Background, isikan Background Color = #DF9300. Selanjutnya, klik
Apply, lalu klik OK.

Di bagia bawah panel CSS Style, klik ikon New Style. Di kotak dialo New Style, pilih tag = h1,
kemudian aktifkan Tag (redefine the look of specific tag), dan klik OK.

Di kotak dialog Style Definition, pada kategori Type, pilih Font =Verdana, Arial, Helvetica, sns serif
Size = 14 pixel, Style = Normal, dan isikan Color = #000000. Klik OK. Di kategori border, hilangkan
semua tanda cek Same for all. Isikan Bottom=solid, thin, #000000. Ini akan membuat border hitam,
tipis di bawah semua elemen <h1>. Klik OK.

Di panel CSS Styles, klik tombol New CSS Style. Di kotak dialog, pilih opsi Tag=h2, pastikan Tag
(redefines the look of specific tag) terpilih dan opsi Define in berisi redefine.css.

Di kotak dialog CSS Style Definition, dalam kategori Type, isikan Size=12 pixels, Style=italic. Di
kategori Background, isikan Background color = #CCC99. Klik OK.

Lihat kode HTML untuk tag<h2> di jendela Inspector, lalu simpan, dan tutup dokumen.

Mendefinisikan Custom Class

1.
2.
3.

Buka file pressrelease.html

Klik ikon New Style di bagian bawah panel CSS Style.

Di kotak dialog New Style, ketikkan .topcopy di kotak isian Name (pastikan di awal nama ada titik)
dan pilih Class (can apply to any tag) untuk option selector type. Pastikan opsi define in berisi (New
Style Sheet File). Klik OK.

Simpan style sheet dengan nama press.css di dalam folder stylesheet. Di kotak dialog CSS Site
Definition, pada kategori Type, isikan Font=Verdana, Arial, Helvetica, sans-serif, Size=10 pixels,
Color=#000000. Di kategori Block, Text align=right. Klik OK.

Di panel CSS Styles, klik tombol New CSS Style dan isikan Name=.header. Klik OK. Di kategori Type,
isikan Font=Georgia, Times New Romans, Times, serid, Size=16 pixels, Styles=italic, Color=#000000.
Dikategori Border, hilangkan tanda cek pada semua opsi Same for ALL. Atur opsi Bottom=solid, thin,
#000000.

Di panel CSS Style, klik tombol New CSS Style. Pastikan Class terpilih dan isikan Name=.bodycopy.
Opsi Define in berisi press.css, klik OK.di kategori Type, isikan Font=Verdana, Arial, Helvetica, sans-
serif, Size= 12 pixels, color=#000000. Klik OK.

Buka jendela Properties Inspector dan klik di baris tanggal di bagian atas halaman dokumen. Di
menu drop-down Style pada Properties Inspector, pilih topcopy.
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8. Ulangilangkah no.7 untuk baris yang berisi “press release” dengan style topcopy, baris teks yang
dimulai dengan kata Dedicated digunakan style header, untuk kelima paragraf teks, gunakan style

.bodcopy.
9. Simpan dan tutup dokumen.

Panel Relevant CSS untuk mengedit CSS Style
1. Buka file pressrelease.html. Pastikan panel Relevant CSS terbuka (Window ->Tag Inspector).

2. Klik di baris kalimat yang diawali kata “Dedicated”. Di panel Relevant CSS, klik kata “solid” disebelah
kanan opsi border-bottom-style. Akan muncul menu drop-down, kemudian pilih dashed. (Perubahan
tidak terlihat di halaman Dreamweaver, tapi akan muncul di browser).

3. Klik beberapa elemen lainnya untuk mengedit di dalam panel Relevant CSS sesuai keinginan anda.

4. Tekan F12 untuk menampilkannya di browser. Simpan dan tutup dokumen.
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Bekerja dengan Template

1.
2.

Gunakanlah folder 06_template sebagai Local oot Folder.

Buka file open eyeworks_color_01.html. File ini dan beberapa file lain yan memiliki templat color
scheme yang sama, yaitu eyeworks_color_02.html dan eyeworks_color_03.htmi.

Buka panel Assets (Window-> Assets), kemudian klik tombl kategori Templates untuk menampilkan
template di halaman anda.

Pilih eyeworks_color di panel Assets, lalu klik ikon Edit di bagian bawah panel tersebut. File
template sudah terbua dan dapat diedit.

Pilih Command->Set Color Scheme. Di kotak dialog, pilih Background : white, Text and Links :
Purple, Orange. Klik Apply, lalu klik OK.

Tutup file template eyeworks_color.dwt dan simpan perubahan yang dilakukan. (Dikotak dialog, klik
Yes). Di kotak dialog Update Template Files, klik Update. Semua file yang menggunakan file ini akan
diperbaharui. Hasil update dapat diketahui di kotak dialog Update Pages yang muncul. Klik Close
untuk menutup kotak dialog .

Buka file eyeworks_color_02.html, eyeworks_color_03.html, eyeworks_color_04.html. perhatikan
bahwa semua file memiliki color scheme yang baru. Tutup semua file.

Membuat Template Baru

1. Buka file sunglasses_01.html. Pilih File->Save as template. Di kotak dialog yang muncul, pastikan
namanya sunglasses_01.html, lalu klik Yes. Klik Yes di kotak dialog yang muncul.

2. Klik di dalam sel atas pada tabel di tengah dokumen. Pilih Insert->Template->Objects-> Editable
Region. Di kotak dialog New Editable Regions, isikan sunglasses_photo dan klik OK.

3. Uangilangkah no.2 untuk sel yang bawabh, isikan sunglasses_info.

4. Tutup file ini dan pastikan anda menyimpannya.

5. Pilih File -> New -> Templates. Di kotak dialog, sorot sunglasses_01, lalu klik Create. Simpan file ini
dengan nama go.html di dalam folder template.

6. Sorot teks “sunglasses_photo” di sel atas dan tekan Delete. Klik tombol Insert Image di Insert bar.

7. Carifile go.jpg , lalu klik Open untuk memasukkannya ke dalam sel.

8. Sorot teks “sunglasses_info”, tekan Delete, ketikkan
Go
These groovy shades are great for the gal or gu who loves to make statemants. Not only are they
styin’ to the max, they’re also lightweight and provie 100% uv protection.
Our GO Sunglasses come in | variety of color combnations that will suit your every mood.

9. Simpan dan biarkan file ini tetap terbuka. Kita akan memakainya di latihan selanjutnya.

Memodifikasi Template

1. Pastikan file go.html masih terbuka. Klik dua kali template sunglasses_01.html di panel Assets
untuk membukanya.

2. Klik di dalam editable region sunglasses_info. Di properties Inspector, klik tombol Align Center.

3. Tutup file ini danpastikan anda menyimpannya. Klik Yes di kotak dialog yang muncul. Bila muncul lagi
kotak dialog, klik update. Lalu klik Close.

4. Simpan dan tutup semua file yang terbuka.
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